Monday, January 12, 2009

HP-UX LVM creation

ex. create /oracle/J1Q/sapdata13 under volume group vg_J1Q_04
using luns c14t1d4(primary) & c14t8d1(alternate)

-->check if fs existed
bdf /oracle/J1Q/sapdata13

--> check the latest disk report
cd /var/opt/soeg/rpt
ll *disk*

--> check for available luns
more 20080423diskinfo.rpt | grep -i lvm | grep -v "0(" | sort -u

-->compares the current hardware configuration (pairing of luns)
xpinfo -il | grep c12t0d1
xpinfo -il | grep 04:28

--> check if controller exists already
pvdisplay /dev/dsk/c14t8d1
pvdisplay /dev/dsk/c14t1d4
vgdisplay -v | grep -iE "c14t8d1|c12t0d1"

ll /dev/*/group | sort -u

-->create directory/device
mkdir /dev/vg_J1Q_04

-->create a character file type group
mknod /dev/vg_J1Q_04/group c 64 0x410000

-->initialize/format physical volume
pvcreate -f /dev/rdsk/c12t0d1

-->create volume group
vgcreate -e 10000 /dev/vg_J1Q_04 /dev/dsk/c12t0d1 /dev/dsk/c14t8d1
vgdisplay /dev/vg_J1Q_04

-->create logical volume
lvcreate -L 8624 -n lv_data13 /dev/vg_J1Q_04

-->construct the new file system
newfs -F vxfs -o largefiles /dev/vg_J1Q_04/rlv_data13

-->create directory
mkdir -p /oracle/J1Q/sapdata13

-->update /etc/fstab

--> mount created new directory
mount /oracle/J1Q/sapdata13

-->check file permission and ownership
chgrp oraj1q:dba sapdata13
chown oraj1q:dba sapdata13


note: the above syntax are derived from true to life experience
and im not liable in case you use it on a production box and
it didn't works. :-)

No comments:

Post a Comment